Issues with logging into Dashboard

Incident Report for Messente

Resolved

This incident has been resolved.
Posted Nov 12, 2025 - 15:34 EET

Investigating

We are experiencing some issues with logins to our dashboard, the issue is being investigated.
Posted Nov 12, 2025 - 15:31 EET
This incident affected: Dashboard (Dashboard).