Issues with logging into Messente Dashboard

Incident Report for Messente

Resolved

The incident has been resolved, and clients are able to log in again.
Posted Sep 15, 2025 - 12:27 EEST

Investigating

We have received reports of users not being able to log in to the Messente Dashboard, and we have started the investigation.
Posted Sep 15, 2025 - 11:38 EEST
This incident affected: Dashboard (Dashboard).