Issues with messages processing

Incident Report for Messente

Postmortem

We identified the root cause to be false-negative health check status in the internal traffic load balancer, causing outage for some critical internal services.
We have temporarily rerouted internal network traffic to avoid the faulty load balancers while the investigation continues internally for the root cause of the healt check problems to ensure this does not happen again.

Posted Jul 15, 2025 - 10:23 EEST

Resolved

This incident has been resolved.
Posted Jul 15, 2025 - 10:18 EEST

Update

Queues have been resolved and processing is back to normal.
Posted Jul 15, 2025 - 10:18 EEST

Update

We have identified the issue and message processing has been restored. Queues are clearing, and we continue to monitor.
Posted Jul 15, 2025 - 10:11 EEST

Investigating

We are currently investigating this issue.
Posted Jul 15, 2025 - 09:53 EEST
This incident affected: Messaging (Omnichannel API, SMS Messaging API, Inbound SMS, Delivery Reports, SMPP, WhatsApp messages, Viber).