Issue with message processing and dashboard login - Resolved

Incident Report for Messente

Resolved

There was an issue with message processing and dashboard login that affected some of the messages and delays the delivery. The issue was caused by a fault in one of the routers on our server provider side. The issue has now been resolved.
Posted Nov 18, 2025 - 12:30 EET