Issue with account balances

Incident Report for Messente

Resolved

This issue has been fixed and all balances should now reflect the current credit correctly.
A post-mortem will be conducted in order to understand the root cause.

We want to thank you for your patience and to apologise for any inconveniences caused!
Posted Apr 11, 2025 - 15:49 EEST

Identified

We have discovered an issue with account balances on prepay accounts. We are investigating the issue and will update you shortly!
Posted Apr 11, 2025 - 13:34 EEST
This incident affected: Dashboard (Billing and Payment).