Issue with Viber messaging

Incident Report for Messente

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 15:39 EEST

Investigating

We are investigating an issue with Viber messages.
Posted Jul 20, 2026 - 12:14 EEST
This incident affected: Messaging (Viber).